در این مطلب، ابعاد مختلف پروتکل FTP چیست؟ را بررسی خواهیم کرد.
اگر برنامه نویس و یا وب مستر باشید، بدون شک FTP را زیاد شنیده اید اما شاید هیچ وقت به دنبال پیدا کردن معنی و کاربرد آن نبوده اید. FTP یا File Transfer Protocol یک پروتکل است که در سال ۱۹۷۱ در بستر اینترنت توسعه یافت. این پروتکل یکی از پرکاربردترین و قدیمیترین پروتکلهای اینترنت است. در ادامه این مطلب میخواهیم ببینیم که پروتکل FTP چیست و چه کاربردهایی در دنیای وب دارد؟ پس اگر به این مبحث علاقه مندید، تا انتهای این مطلب همراه ما باشید.

پروتکل اف تی پی یا FTP در سال ۱۹۷۱ توسط Abhay Bhushan و تحت عنوان RFC114 منتشر گردید. همانطور که از نام این پروتکل مشخص است، FTP وظیفه انتقال فایلها از یک کامپیوتر به کامپیوتر دیگری را برعهده دارد. این پروتکل با هدف ارائه روشی استاندارد برای انتقال فایل در شبکه ای کوچک از کامپیوترها ایجاد شد. این شبکه شامل چند مرکز نظامی، دانشگاهی و عده کمی از افراد می شد. در ابتدای ایجاد این پروتکل شبکه از تعداد مشخص و کمی از کامپیوترها و استفادهکنندگان تشکیل شده بود. از این رو مسائل امنیتی در نسخه جدیدهای اولیه پروتکل FTP از اهمیت چندانی برخوردار نبود.
اما به تدریج و با گسترش شبکه کامپیوتر و صعود ناگهانی مخاطبان آن نیاز به در نظر گرفتن مسائل امنیتی احساس شد. بنابراین به منظور پر کردن این خلا امنیتی، بروزرسانیهای RFC 2228 و RFC 2428 برای این پروتکل ارائه شدند. FTP يک پروتکل استاندارد بر پایه TCP/IP است. معمولا ارتباط در این پروتکل از طریق پورتهای 20 و 21 برقرار میشود. پورت 21 به منظور ارتباط میان سرور و کلاینت و پورت 20 برای تبادل و ارسال فایلها در شبکه مورد استفاده قرار میگیرد.
استفاده از پروتکل FTP به منظور انتقال فایلها به یک سیستم دیگر، نیازمند دو پیش نیاز اصلی میباشد. این پیش نیازها عبارتند از :
به صورت کلی سه راه برای استفاده از FTP وجود دارد که عبارتند از :

از FTP برای انتقال فایلها بین حسابهای یک کامپیوتر، بین دو کامپیوتر مختلف و... در یک شبکه استفاده می شود. معمولا وب مستران برای انتقال محتوای مختلف به سايتها از FTP استفاده میکنند. زیرا معمولا زمانی که بخواهند یک فایل را از یک سیستم در هاست آپلود کنند، FTP بهترین گزینه برای این کار خواهد بود. در ادامه از FTP میتوان برای اشتراک گذاری فایلها استفاده کرد. مثلا زمانی که بخواهند دسترسی به یک فایل را از طریق لینک در اختیار سایر استفادهکنندگان قرار دهند. کاربردهای این پروتکل به صورت کلی عبارتند از :
بیشتر بخوانید:پروتکل https چیست؟
همانطور که اشاره شد زمانی که پروتکل FTP ارائه شده بود، شبکه کامپیوترها بسیار کوچک و محدود بود. بنابراین در آن زمان صحبتی از امنیت سایبری و رعایت نکات امنیتی در برقراری ارتباطات به میان نیامده بود. این مبحث به این مساله اشاره میکند که ارتباطات در پروتکل FTP رمزنگاری (Encrypted) نمی شوند.
بر این اساس اگر کسی به مسیر ارتباطی FTP دسترسی پیدا کند به راحتی میتواند عملیاتهای انجام شده را مطالعه کند. حتی توانایی دارد به راحتی با تغییر و یا پاک کردن فایل ها، اطلاعات سایت را به خطر بیندازد. بنابراین در زمان حاضره اکثر استفادهکنندگان از FTPS استفاده میکنند. FTPS گزارشها و ارتباطات رمزنگاری میشوند تا هکرها، خرابکارها و یا هر کاربر غیرمجاز دیگری نتواند به فایلهای سرور دسترسی داشته باشد.
پروتکل اف تی پی یا FTP وظیفه انتقال فایلها از کامپیوتری به کامپیوتر دیگری را برعهده دارد. این پروتکل با هدف ارائه روشی استاندارد برای انتقال فایل در شبکه ای کوچک از کامپیوترها ایجاد شد. از این پروتکل برای انتقال فایلها بین حسابهای یک کامپیوتر، بین دو کامپیوتر مختلف و... در یک شبکه استفاده می شود.
منبع : سون لرن
B L O G F A . C O M
آخرین اطلاعات منتشر شده در همین صفحه بهروزرسانی خواهد شد.
تمام اطلاعات بر اساس گزارشهای منتشر شده در زمان نگارش این مطلب تهیه شده است.
جدیدترین جزئیات و تغییرات مربوط به این موضوع در متن گزارش آمده است.
برچسب:
نویسنده: آروین پورعلی